Reef Central Online Community
Live Aquaria

Home Forum Here you can view your subscribed threads, work with private messages and edit your profile and preferences View New Posts View Today's Posts

Find other members Frequently Asked Questions Search Reefkeeping ...an online magazine for marine aquarists Support our sponsors and mention Reef Central

Go Back   Reef Central Online Community > Sponsor Forums > EcoTech Marine
Register Blogs FAQ Calendar Mark Forums Read

Notices

User Tag List

Reply
Thread Tools
Old 04/11/2018, 02:42 PM   #1
gtareef
Registered Member
 
gtareef's Avatar
 
Join Date: Apr 2015
Location: Toronto, Canada
Posts: 46
Thumbs down MP40QD wet side rusted

I had three of the QD version wet side magnet popped out and no longer working. Never had this issue with the older models? I have been using Ecotech power heads over the last 9 years and it seems like quality has gone down over the past 2-3 years. Anyone have this issue or it is just me?


Attached Images
File Type: jpg Photo 2018-03-16, 12 42 44 AM.jpg (50.5 KB, 51 views)
File Type: jpg Photo 2018-03-16, 12 43 50 AM.jpg (52.6 KB, 51 views)
File Type: jpg Photo 2018-03-16, 12 44 24 AM.jpg (44.2 KB, 52 views)
__________________
SPS Dominated. Miracles 270g starphire C2C external overflow, BK200, ATI PM, Georeef KR618, CR618 with CarbonDoser Co2, Apex, WXM, PM2, Auto feeder.
Coral ID - http://www.coralid.ca

Current Tank Info: SPS Dominated Reef Aquarium
gtareef is offline   Reply With Quote
Old 04/11/2018, 02:53 PM   #2
ramseynb
Registered Member
 
Join Date: Nov 2010
Location: New Braunfels, TX
Posts: 597
I've heard it happening to other people too. I bought a new wet side recently. I guess I'll be needing to check it regularly! It's an MP10 though and I think the other issues I've seen have been with MP40s. I'm not sure why they needed to fix something that wasn't broke. The old wet side were just fine IMO.


__________________
How do you make an octopus laugh?

Ten tickles!
ramseynb is offline   Reply With Quote
Old 04/11/2018, 02:55 PM   #3
rvareef
Registered Member
 
Join Date: Jun 2014
Posts: 432
http://www.reefcentral.com/forums/sh....php?t=2621134


rvareef is offline   Reply With Quote
Old 04/11/2018, 03:21 PM   #4
DivingTheWorld
Registered Member
 
DivingTheWorld's Avatar
 
Join Date: Sep 2013
Location: San Ramon, CA
Posts: 1,548
I had it happen to one of my QDs. Ecotech swapped it out free of charge. Luckily I had a backup wetside so didn't suffer any down time. I check my magnets with every cleaning now (every 4 months or less).


__________________
Current Tank Info: LeeMar Rimless (40x24x22), ATI 8x39 Dimmable w/Reefbrite Tech, 2x Vortech MP40w QD w/ Battery Backup, Apex Gold, Trigger Systems Ruby30S, Reef Octopus POV-DC1 w/Auto Waste Collector
DivingTheWorld is offline   Reply With Quote
Old 04/11/2018, 03:34 PM   #5
gtareef
Registered Member
 
gtareef's Avatar
 
Join Date: Apr 2015
Location: Toronto, Canada
Posts: 46
Quote:
Originally Posted by rvareef View Post
OMG! I lost 70% of my SPS last April and could not figure it out. Anyway, about 10 months ago I noticed the wet side keeps falling off every time I turn on the MP, but I did not know that the magnet popped and could not spin. Some colonies I had for 8 years started to stn, which I find weird because I know they are hardy. Anyway, now I noticed two more QD are doing the same. FYI, two of my 6 years old tunze are still running fine with little maintenance.

I called Ecotech and asked them about the quality and if anyone have complained about the rusted wet side. They told me no, and since my wet side is over 1 year they will not honour the warranty. I am ok with that, but if I spent $500 for a pump, I would expect it to last more than 2 years.

I owned about 8 MPs and have always recommended them to local reefers. I'm very disappointed in the quality.


__________________
SPS Dominated. Miracles 270g starphire C2C external overflow, BK200, ATI PM, Georeef KR618, CR618 with CarbonDoser Co2, Apex, WXM, PM2, Auto feeder.
Coral ID - http://www.coralid.ca

Current Tank Info: SPS Dominated Reef Aquarium
gtareef is offline   Reply With Quote
Old 04/12/2018, 09:12 AM   #6
slap
Registered Member
 
Join Date: Mar 2013
Location: Germany
Posts: 96
It was clear that ecotech has never heard of it


__________________
Aqua Medic Xenia 130: 3x Ecotech Radion XR30w G4 Pro - 2x Vortech MP40 QD - 2x Vortech Mp10 QD - Ecotech Vectra M1 - Nyos Quantum 120
slap is offline   Reply With Quote
Old 04/12/2018, 03:24 PM   #7
gtareef
Registered Member
 
gtareef's Avatar
 
Join Date: Apr 2015
Location: Toronto, Canada
Posts: 46
I think I will be switching to Tunze from now one. One wet side goes bad I can take, but when all three newer QD wet side goes bad. I think Ecotech need to do a better job and back up their products.


__________________
SPS Dominated. Miracles 270g starphire C2C external overflow, BK200, ATI PM, Georeef KR618, CR618 with CarbonDoser Co2, Apex, WXM, PM2, Auto feeder.
Coral ID - http://www.coralid.ca

Current Tank Info: SPS Dominated Reef Aquarium
gtareef is offline   Reply With Quote
Old 04/12/2018, 06:50 PM   #8
tgbaby1
Premium Member
 
tgbaby1's Avatar
 
Join Date: Feb 2007
Location: KC
Posts: 156
MP40QD wet side rusted

Found the same thing this week, ET said they will replace it and my pump is almost 3yrs old. Very disappointing for a “premium” product, but so far customer service has been good.




tgbaby1 is offline   Reply With Quote
Old 04/12/2018, 07:57 PM   #9
gtareef
Registered Member
 
gtareef's Avatar
 
Join Date: Apr 2015
Location: Toronto, Canada
Posts: 46
Mine is newer than yours but they won’t replace. I guess it depends on which tech you deal with. The tech I was dealing with doesn’t care too much about my issue.

I helped a lot people setting new tanks and have always recommended Neptune and Ecotech. Too bad I can’t say good things about Ecotech any more.


__________________
SPS Dominated. Miracles 270g starphire C2C external overflow, BK200, ATI PM, Georeef KR618, CR618 with CarbonDoser Co2, Apex, WXM, PM2, Auto feeder.
Coral ID - http://www.coralid.ca

Current Tank Info: SPS Dominated Reef Aquarium
gtareef is offline   Reply With Quote
Old 04/13/2018, 03:26 PM   #10
gtareef
Registered Member
 
gtareef's Avatar
 
Join Date: Apr 2015
Location: Toronto, Canada
Posts: 46
Just saw this on FB. Another person facing the same issue.


Attached Images
File Type: jpg E95D116A-330C-42B9-93F3-4EAD6551064F.jpg (73.9 KB, 28 views)
__________________
SPS Dominated. Miracles 270g starphire C2C external overflow, BK200, ATI PM, Georeef KR618, CR618 with CarbonDoser Co2, Apex, WXM, PM2, Auto feeder.
Coral ID - http://www.coralid.ca

Current Tank Info: SPS Dominated Reef Aquarium
gtareef is offline   Reply With Quote
Old 04/15/2018, 11:54 AM   #11
Sisterlimonpot
R.C. Fraternity President
 
Sisterlimonpot's Avatar
 
Join Date: Dec 2008
Location: Litchfeild Park AZ
Posts: 11,002
Blog Entries: 2
This is a common problem with these pumps. A previous post from Ecotech defended that the number of magnets that swell are well within acceptable limits and don't have plans to do anything except replace the ones that fall under warranty.

It's the nature of the beast, if the plastic that seals the magnet allows any salt water to touch it, it's only a matter of time before this happens.


__________________
Jimmy
MASVC President

Dishes are done man!

Current Tank Info: 300 in progress
Sisterlimonpot is offline   Reply With Quote
Old 04/16/2018, 02:33 PM   #12
ca1ore
Grizzled & Cynical

 
Join Date: Apr 2006
Location: Stamford, CT
Posts: 17,044
I have no idea whether it's a common problem; nor do you. It certainly appears to have been an issue for the early QD models. I own three MP40 QD models, all bought when they first came out (3 years? lost track), and all have been fine, so those are my 'data points'. Seems ETM is pretty good about replacing them, at least if you live in the US. FWIW, swelling/split impeller magnets is something we all should be regularly checking for. I'm on my third one for my old sedra pump.


__________________
Simon

Got back into the hobby ..... planned to keep it simple ..... yeah, right ..... clearly I need a new plan! Pet peeve: anemones host clowns; clowns do not host anemones!

Current Tank Info: 450 Reef; 120 refugium; 60 Frag Tank, 30 Introduction tank; multiple QTs
ca1ore is offline   Reply With Quote
Old 04/16/2018, 09:49 PM   #13
gtareef
Registered Member
 
gtareef's Avatar
 
Join Date: Apr 2015
Location: Toronto, Canada
Posts: 46
another one failed today. Just my luck. Will call Ecotech tomorrow and see what they can do.


Attached Images
File Type: jpg Photo 2018-04-16, 11 35 55 PM.jpg (69.4 KB, 13 views)
File Type: jpg Photo 2018-04-16, 11 34 03 PM.jpg (57.0 KB, 12 views)
__________________
SPS Dominated. Miracles 270g starphire C2C external overflow, BK200, ATI PM, Georeef KR618, CR618 with CarbonDoser Co2, Apex, WXM, PM2, Auto feeder.
Coral ID - http://www.coralid.ca

Current Tank Info: SPS Dominated Reef Aquarium
gtareef is offline   Reply With Quote
Old 04/17/2018, 09:55 AM   #14
Sisterlimonpot
R.C. Fraternity President
 
Sisterlimonpot's Avatar
 
Join Date: Dec 2008
Location: Litchfeild Park AZ
Posts: 11,002
Blog Entries: 2
Quote:
Originally Posted by ca1ore View Post
I have no idea whether it's a common problem; nor do you. It certainly appears to have been an issue for the early QD models. I own three MP40 QD models, all bought when they first came out (3 years? lost track), and all have been fine, so those are my 'data points'. Seems ETM is pretty good about replacing them, at least if you live in the US. FWIW, swelling/split impeller magnets is something we all should be regularly checking for. I'm on my third one for my old sedra pump.
Unfortunately, after I exhausted my search, Tim must have petitioned to have that entire thread removed because I can't find it anymore, it's lost in the mod section now. We will have to agree to disagree.

Paraphrased, it stated that the majority of people that report (on forums) the negative about a product versus the positive will always outshine, and through their research the number of magnets that split are far lower than whatever threshold they set for this problem.

In my hobby experience, I have owned 15 separate pumps and out of those, 3 have had split magnets. That's 1/5 or 20%. I might also add that they were all mp40s, in my hobby experience I have owned 7 (out of the 15) mp40s, meaning 3/7 or 43% of them had split magnets. I'm not saying that these are hard numbers that ecotech has as well, a more accurate picture can easily be painted with their reported numbers. However, I would also consider how many people out there aren't even aware that their magnet has split and goes unreported.

From a business aspect I understand their position, from a consumer stand point, this should be a non issue, no one should experience this problem. And that's the frustration that many of these guys are having.


__________________
Jimmy
MASVC President

Dishes are done man!

Current Tank Info: 300 in progress
Sisterlimonpot is offline   Reply With Quote
Old 04/17/2018, 10:21 AM   #15
ca1ore
Grizzled & Cynical

 
Join Date: Apr 2006
Location: Stamford, CT
Posts: 17,044
Fair enough. It would actually be interesting if folks would publish their numbers as you have done. In my case, I've owned 14 vortech pumps - 6 old style MP40 (only have one left), 3 new style QD MP40, 2 MP60 and 3 MP10. I inspect and clean the wetsides every other month. I dropped one of the old MP40, oops, and sold off four. None had split or rusted magnets. I replaced the remaining old style MP40 wetside last year after 5 years of use, no split but it had developed an unfixable wobble. Two MP60s are three years old and on their original wetsides, no splits. One MP10 got water in the dryside so kaput; other two are QD models and no splits. Maybe I'm just lucky.


__________________
Simon

Got back into the hobby ..... planned to keep it simple ..... yeah, right ..... clearly I need a new plan! Pet peeve: anemones host clowns; clowns do not host anemones!

Current Tank Info: 450 Reef; 120 refugium; 60 Frag Tank, 30 Introduction tank; multiple QTs
ca1ore is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:44 AM.


TapaTalk Enabled

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Use of this web site is subject to the terms and conditions described in the user agreement.
Reef CentralTM Reef Central, LLC. Copyright ©1999-2014
User Alert System provided by Advanced User Tagging v3.3.0 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.